Exam 400-101 | Question id=1167 | Layer 2 Technologies |
You want to connect four ports on two switches in an EtherChannel configuration. SwitchEast is a Cisco switch, and SwitchWest is a nonCisco switch.
Which of the following command sets should you issue to configure interfaces Gi 2/1 through Gi 2/4 on SwitchEast?
A. |
SwitchEast(config)#interface port-channel 1
SwitchEast(config-if)#ip address 10.20.30.40 255.255.255.0
SwitchEast(config-if)#interface range gi 2/1 4
SwitchEast(config-if-range)#no ip address
SwitchEast(config-if-range)#channel-protocol pagp
SwitchEast(config-if-range)#channel-group 1 mode active
| |
B. |
SwitchEast(config)#interface port-channel 1
SwitchEast(config-if)#ip address 10.20.30.40 255.255.255.0
SwitchEast(confi-gif)#interface range gi 2/1 4
SwitchEast(config-if-range)#no ip address
SwitchEast(config-if-range)#channel-protocol pagp
SwitchEast(config-if-range)#channel-group 1 mode desirable non-silent
| |
C. |
SwitchEast(config)#interface port-channel 1
SwitchEast(config-if)#ip address 10.20.30.40 255.255.255.0
SwitchEast(config-if)#interface range gi 2/1 4
SwitchEast(config-if-range)#no ip address
SwitchEast(config-if-range)#channel-protocol lacp
SwitchEast(config-if-range)#channel-group 1 mode active
| |
D. |
SwitchEast(config)#interface port-channel 1
SwitchEast(config-if)#ip address 10.20.30.40 255.255.255.0
SwitchEast(config-if)#interface range gi 2/1 4
SwitchEast(config-if-range)#no ip address
SwitchEast(config-if-range)#channel-protocol lacp
SwitchEast(config-if-range)#channel-group 1 mode desirable non-silent
|
You should issue the following command set to configure interfaces Gi 2/1 through Gi 2/4 on SwitchEast:
SwitchEast(config)#interface port-channel 1
SwitchEast(config-if)#ip address 10.20.30.40 255.255.255.0
SwitchEast(config-if)#interface range gi 2/1 4
SwitchEast(config-if-range)#no ip address
SwitchEast(config-if-range)#channel-protocol lacp
SwitchEast(config-if-range)#channel-group 1 mode active
These commands configure a Link Aggregation Control Protocol (LACP) EtherChannel on SwitchEast. LACP is defined in the Institute of Electrical and Electronics Engineers (IEEE) 802.3ad standard. Because LACP is a standardsbased protocol, it can be used between Cisco and nonCisco switches.
The interface portchannel 1 command creates port channel interface 1; the port channel interface number can be any number from 1 through 64. The ip address 10.20.30.40 255.255.255.0 command assigns the IP address 10.20.30.40/24 to the port channel interface. The interface range gi 2/1 4 command enters interface configuration mode for interfaces Gi 2/1 through Gi 2/4, and the no ip address command ensures that no IP address is configured for any of the interfaces that will belong to the channel group.
The channel-protocol lacp command configures the interfaces for LACP operation. The channelgroup 1 mode active command configures the interfaces for channel group 1 in active mode. The syntax of the channelgroup command is channel group numbermode {on | active | passive | {auto | desirable} [nonsilent]}, where number is the port channel interface number. The auto, desirable, and nonsilentkeywords can be used only with Port Aggregation Protocol (PAgP). The on keyword configures the channel group to unconditionally create the channel with no LACP negotiation. The active keyword configures the channel group to actively negotiate LACP, and the passive keyword configures the channel group to listen for LACP negotiation to be offered.
PAgP is a Ciscoproprietary protocol. Therefore, PAgP cannot be used to create an EtherChannel between SwitchEast and SwitchWest; it can only be used to create an EtherChannel between two Cisco switches.
The following command set is invalid because the desirable and nonsilent keywords cannot be used with LACP:
SwitchEast(config)#interface port-channel 1
SwitchEast(config-if)#ip address 10.20.30.40 255.255.255.0
SwitchEast(config-if)#interface range gi 2/1 4
SwitchEast(config-if-range)#no ip address
SwitchEast(config-if-range)#channel-protocol lacp
SwitchEast(config-if-range)#channel-group 1 mode desirable non-silent